Alert Logic Support Telephone Number
Incident Report for Alert Logic
Resolved
This incident is now resolved. UK Customers can now continue to contact our Support Team by telephone on +44 203 011 5533
Posted Mar 17, 2022 - 14:31 UTC
Update
Customers are now able to contact our Support teams on our US number +1 877 484 8383. We are continuing to investigate an outstanding issue with inbound phone calls to our UK number.
Posted Mar 17, 2022 - 13:31 UTC
Investigating
We are investigating an issue with our phone system, affecting inbound customer calls. If you need to raise or follow up on a ticket with Alert Logic Support during this time, please submit a ticket via the support portal - https://support.alertlogic.com/hc/ or contact us via email - support@alertlogic.com
Posted Mar 17, 2022 - 12:49 UTC
This incident affected: US-West-1 (Business Systems), US-East-1 (Business Systems), and UK-West-1 (Business Systems).