Alert Logic Support E-mail
Incident Report for Alert Logic
Resolved
Microsoft have confirmed that the issue affecting e-mail delivery in the North America region is now resolved. Customers are now able to contact Alert Logic Support via e-mail without any further issues expected.
Posted Feb 04, 2021 - 03:02 UTC
Monitoring
We are currently aware of an issue with Microsoft O365, which is affecting e-mail delivery for users in the North America region. We are monitoring for updates from the vendor. During this Incident, customers are advised to contact Alert Logic via phone or the Help Center - details can be found at https://support.alertlogic.com/hc/en-us
Posted Feb 03, 2021 - 23:57 UTC
This incident affected: US-West-1 (Alert Logic Console) and US-East-1 (Alert Logic Console).